Login
Community
DARK THEME

microStudio on itch.io - including an app for Raspberry Pi !

microStudio game engine can now work as a standalone (offline) app for Windows, macOS, Linux and now Raspberry Pi! To celebrate this, I have created this page on itch.io for microStudio:

https://microstudio.itch.io/microstudio

All the downloads are available there, as well as on Github.

I will try to update the app on a monthly basis :-)

Go Folks
Support it by rating it on itchio :)

I tried it on my Pi, but it just says this: Segmentation Fault (core dumped) My only guess is I'm using an ARM64 OS (Ubuntu Desktop), not ARMHF, but I have multiarch activated. Any help?

Also will there be Pi exports?

@hadcl4 I just had the opportunity to check on a Raspberry Pi 4 with Pi OS (Raspbian), and a Pi 400 with Pi OS (the app is working on both). Maybe if you like to experiment, you could try to build the app yourself, following this recipe: https://microstudio.dev/community/articles/recipe-standalone-microstudio-app---work-in-progress/243/ Let me know what you get!

Pi exports: yes definitely! I will look into it sometime, shouldn't be too hard now that I have a working build process on Raspberry Pi.

Tried building it, but failed with the npm run make command:

An unhandled rejection has occurred inside Forge:
Error: Cannot make for rpm, the following external binaries need to be installed: rpmbuild
    at MakerRpm.ensureExternalBinariesExist (/home/user/microstudio-standalone/microstudio/server/node_modules/@electron-forge/maker-base/src/Maker.ts:147:13)
    at _default (/home/user/microstudio-standalone/microstudio/server/node_modules/@electron-forge/core/src/api/make.ts:155:11)
    at /home/user/microstudio-standalone/microstudio/server/node_modules/@electron-forge/cli/src/electron-forge-make.ts:44:5

Electron Forge was terminated. Location:
{}

I'm not used to NPM, so I'm not sure what the error means (most of my programs are in Python, not JS).

As @JimB007 found out, on Linux systems you will need to install rpm, you do this as follows:

sudo apt install rpm

I will update the recipe accordingly.

Just tried again, made it farther, but then it comes up with an error saying the license field is missing, even though I entered it in (as MIT). Maybe just microStudio can't compile on an ARM64 OS?

Post a reply

Progress

Status

Preview
Cancel
Post
Validate your e-mail address to participate in the community